Mendix Cloud v4 EU - Connectivity issues
Incident Report for Mendix Technology B.V.
Resolved
This incident has been resolved.

A major malfunction in an AWS service affecting a single availability zone in eu-central-1 (Frankfurt) region made our web servers unavailable for some time. This made apps running in this region unreachable for some time, although they were still running. In order to restore service, we deployed and alternative web server solution, bypassing the malfunctioning AWS service. As soon as we verified the AWS service was operating normally again, we switched back to normal operations. We’re keeping the workaround on hot standby so we can restore service on very short notice, should this issue recur.
Posted Jun 11, 2021 - 09:47 CEST
Update
We are continuing to monitor for any further issues.
Posted Jun 11, 2021 - 09:43 CEST
Update
We are continuing to monitor for any further issues.
Posted Jun 11, 2021 - 00:50 CEST
Monitoring
We have failed over the impacted infrastructure that was heavily impacting the platform and the applications on the Frankfurt cluster.
We are seeing that the apps are once again accessible starting 12:30AM CEST.
We are still monitoring the situation closely.
Posted Jun 11, 2021 - 00:49 CEST
Update
We are currently impacted by service interruption by AWS Frankfurt causing Mendix Platform and customer apps hosted in Frankfurt region to be unavailable at this time.
Due to the connectivity issues at AWS we are observing that the below services are also impacted-

- Login service
- App deployments
- Backups
- Logging, monitoring and alerting
- Marketplace
- Platform APIs

We are looking into the issue currently and working closely with AWS team.
Posted Jun 11, 2021 - 00:11 CEST
Investigating
Amazon Elastic Compute Cloud (Frankfurt) is suffering from connectivity issues and as a result our Cloud V4 infrastructure is impacted. We are currently investigating the issue.
Posted Jun 10, 2021 - 23:25 CEST
This incident affected: Mendix Services (Project Management, Control Center, Team Server, Studio Pro, Academy, Support Portal, Catalog, Deploy - Mendix Cloud, Deploy - SAP Cloud), Mendix for Private Cloud (Deploy / Operate - Mendix for Private Cloud), Mendix Cloud (Mendix Cloud EU (Frankfurt)), and Mendix Cloud Dedicated (Mendix Cloud Dedicated EU).