DNS Issue impacting site availability
Incident Report for Mendix Technology B.V.
Resolved
The incident has been resolved.
Posted Apr 26, 2024 - 11:44 CEST
Update
We are continuing to monitor the situation closely following the identification and reversion of the DNSSEC changes. We are observing improvements in site availability as DNS changes propagate.

To workaround this issue until DNS changes propagate to your ISP, you can make use of Cloudflare's or Google's public DNS resolvers which already return the updated records.
Please visit the following pages for details on how to configure this workaround on your system:

- Cloudflare: https://developers.cloudflare.com/1.1.1.1/setup/
- Google: https://developers.google.com/speed/public-dns/docs/using
Posted Apr 25, 2024 - 13:13 CEST
Monitoring
We are continuing to monitor the situation closely following the identification and reversion of the DNSSEC changes. We are observing improvements in site availability as DNS changes propagate.

Impact:

- Some customers may still experience intermittent availability issues as DNS changes propagate fully.
- Services reliant on the affected domain may also continue to experience disruption until DNS caches are refreshed.

We appreciate your patience and understanding throughout this process. Rest assured, we remain committed to restoring normal operations as swiftly as possible.
Posted Apr 25, 2024 - 12:20 CEST
Identified
We've identified the root cause of the DNS issue impacting the availability of all our sites associated with the domain mendix.com. The issue stemmed from recent DNSSEC changes. We have promptly reverted the change to restore service.

Please note that it may take some time for the changes to propagate fully due to the nature of DNS.
In the meantime, you can try clearing the local cache of your system and attempting to access our sites again.

Impact:

Customers may still experience intermittent availability issues as DNS changes propagate.
Services reliant on the affected domain may also continue to experience disruption until DNS caches are refreshed.
Posted Apr 25, 2024 - 12:03 CEST
Investigating
We're currently experiencing a DNS issue that is impacting the availability of all our sites associated with the domain mendix.com. Our team is actively investigating the issue to identify the root cause and implement a resolution as quickly as possible.

Impact:

Customers may experience intermittent or complete inability to access our sites.
Services reliant on the affected domain may also experience disruption.
Posted Apr 25, 2024 - 11:42 CEST
This incident affected: Mendix Services (Control Center, Marketplace, Community, Academy, Catalog, Deploy - Mendix Cloud, Logs and Metrics - Mendix Cloud).