All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Cloud (Frankfurt)- Missing logs on subset of apps

Incident Report for Mendix Technology

Resolved

The incident has been resolved. Application logs and access logs are available after the fix. Unfortunately we won't be able to recover the missing logs. We apologize for the inconvenience caused by this outage.
Posted May 22, 2026 - 09:01 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Note on log retention: For the affected environments, application and access logs between 13:00 UTC on 20 May 2026 and the time of resolution are not recoverable. Customers reviewing log data from this window will see a gap covering this period.
Posted May 21, 2026 - 13:17 UTC

Identified

The root cause has been identified and a fix is being implemented. No further customer action is required at this time.
Posted May 21, 2026 - 13:04 UTC

Investigating

Some applications in Mendix Cloud EU (Frankfurt) may not be displaying recent logs. If you are unable to view logs from the last few hours, your environment is likely affected. The team is actively investigating.
Posted May 21, 2026 - 12:49 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud EU (Frankfurt)) and Mendix Cloud Services (Logging, Monitoring, and Alerting).