All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Accidental Test Email Sent

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 09:32 UTC

Investigating

An automated message was sent earlier from Mendix Support with the title “A message from Mendix Support” to some recipients.

Please disregard this message, if you received it as it was sent in error.

We apologize for any confusion and appreciate your understanding.
Posted Jan 28, 2026 - 11:25 UTC