This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
The situation hasn't changed. We have seen no improvement in affected services. The vendor is working hard to restore their services, but didn't provide an ETA when services are restored.
We will update the incident as events warrant.
Posted Mar 03, 2026 - 15:53 UTC
Update
We have identified an issue with an upstream vendor due to a regional incident, causing applications in that region to be unavailable. The vendor is working hard to restore their services, but didn't provide an ETA when services are restored.
As mentioned in our previous message customers using the premium plan are not affected.
We will update the incident as events warrant.
Posted Mar 02, 2026 - 15:39 UTC
Identified
We have identified an issue with an upstream vendor due to a regional incident, causing applications in that region to be unavailable. Customers using the premium plan will not be affected.
We will update the incident as events warrant.
Posted Mar 02, 2026 - 08:21 UTC
Investigating
We are experiencing some difficulties reaching the Middle East (Bahrain) region.
Posted Mar 02, 2026 - 05:48 UTC
This incident affects: Mendix Cloud Regions (Mendix Cloud Middle East (Bahrain)).