All systems remain stable, and no further issues have been reported since our last update. Please reach out to Mendix Support if you experience any problems.
Posted Jun 24, 2025 - 19:53 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 24, 2025 - 15:50 UTC
Monitoring
We will continue monitoring to ensure ongoing system stability
Posted Jun 24, 2025 - 15:26 UTC
Update
The underlying issue caused by recent maintenance has been resolved. All applications should now be up and running. Please redeploy your applications if you encounter any issues.
Posted Jun 24, 2025 - 15:12 UTC
Identified
We are aware that certain applications in the Mendix Cloud Dedicated EU (Frankfurt) Sierra cluster are currently unreachable.
Our technical team is actively investigating and working to restore applictions promptly. Further updates will follow as we have more information.
Posted Jun 24, 2025 - 15:03 UTC
This incident affected: Mendix Cloud Dedicated (Mendix Cloud Dedicated EU (Frankfurt) Sierra).