This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
A fix has been implemented and we're monitoring the results. Users are advised to clear their browser cache or logout and login again to Mendix Portal.
Posted Mar 26, 2026 - 09:29 UTC
Investigating
We're currently investigating issues with logs, metrics and alerts on Mendix Portal. Those pages are currently inaccessible.
Posted Mar 26, 2026 - 08:09 UTC
This incident affects: Mendix Cloud Services (Logging, Monitoring, and Alerting).