Mendix for Private Cloud Portal degraded performance
Incident Report for Mendix Technology B.V.
Resolved
The issue regarding deployment packages seems to be resolved.
The features which we've reverted will be available in the next Private Cloud Portal release.
Posted May 13, 2022 - 12:58 CEST
Monitoring
We've reverted back to the previous version of the Private Cloud Portal.

The missing deployment packages issue seems to have been caused by the degraded performance of our database due to a large number of stored deployment packages.
To fix this, we've decided to clean up all deployment packages older than two months, which we're not deployed to an environment.
This should improve the overall performance and responsiveness of the Private Cloud Portal until we find a more permanent solution.

We're going to continue monitoring this issue.
Posted May 12, 2022 - 21:05 CEST
Identified
We've decided to revert the Private Cloud Portal to the previous stable version.
This will create a small downtime and unfortunately, all bug fixes/new features introduced with the latest update will also be lost, for now.
Once everything is stable, we'll provide a future release in which we're going to reintroduce the lost bug fixes/new features.
Posted May 12, 2022 - 20:23 CEST
Investigating
We are currently investigating an issue related to missing deployment packages in the Private Cloud Portal.
Posted May 12, 2022 - 19:11 CEST
This incident affected: Mendix for Private Cloud (Deploy / Operate - Mendix for Private Cloud).