A fix has been implemented for the issue, and we expect that the backups restore operation works as expected now. It is possible that due to the ongoing maintenances for database minor version upgrades, your application environment has been upgraded to PostgresSQL 13.10. We expect for these environments the issue will still exist. In case you are facing issues while performing a backup restore for one of your application environments, please reach out to the Mendix Support team.
Posted Mar 22, 2023 - 16:17 UTC
Identified
The issue has been identified, and our engineers are currently working towards a fix. The impact is limited to the customer environments running on PostgreSQL version 13.10. Once the fix is ready, tested and released we will update this page with more details.
Posted Mar 21, 2023 - 15:51 UTC
Investigating
We are currently investigating an issue with backups restore feature on the Mendix Cloud platform. From the initial research our engineers have found an issue with the latest version of PostgresSQL 13.10 which is incompatible with the restore service. For now, we suggest to not perform any upgrades or downgrades on the databases until this issue is resolved.
Posted Mar 21, 2023 - 10:19 UTC
This incident affected: Mendix Cloud (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud Free Tier EU, Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud: Backups, Mendix Cloud: Logging, Monitoring, and Alerting Services).