All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Software Composition degraded processing of new packages

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 10:27 UTC

Investigating

We have observed some degradations in processing of new build packages for Software Composition both from Control Center & Developer Portal view. The team is currently investigating.
Posted Oct 14, 2025 - 13:23 UTC
This incident affected: Mendix Services (Software Composition).