All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

Page load times are back to normal for Mendix Portal. This incident has been resolved.
Posted Sep 10, 2025 - 14:09 UTC

Investigating

We have observed and are investigating degraded performance of the Mendix Portal. Page loads are taking longer than expected.
Posted Sep 10, 2025 - 12:53 UTC
This incident affected: Mendix Services (Mendix Portal).