All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

DNS issues in subset of Mendix Cloud regions

Incident Report for Mendix Technology

Resolved

Following our last update, continuous monitoring has shown no recurrence of issues related to the DNS issues.

This incident is now resolved.
We appreciate your patience and understanding throughout this process.
Posted Oct 28, 2025 - 13:06 UTC

Monitoring

We're pleased to inform you that our engineering teams have successfully implemented a fix for the DNS resolution issue we've been experiencing. We are now actively monitoring our systems to ensure full restoration of service and stability across all affected areas.

We sincerely apologize for any disruption, inconvenience, or impact on your operations caused by this incident. We truly appreciate your patience and understanding as we navigated these challenges.
Posted Oct 28, 2025 - 11:20 UTC

Identified

Our teams have identified the issue and are currently working on a fix.
At this moment only custom domains are affected, so we advise not to change custom domains for environments.
Posted Oct 28, 2025 - 11:11 UTC

Investigating

We've identified an issue impacting DNS resolution in a subset of our clusters. Our team are currently working with the highest priority to investigate the root cause and implement a fix.
Posted Oct 28, 2025 - 10:58 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud US-East, Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud Middle East (UAE), Mendix Cloud South America (São Paulo), Mendix Cloud Asia Pacific (Osaka), Mendix Cloud Asia Pacific (Seoul), Mendix Cloud Asia Pacific (Jakarta)).