Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2025 - 10:00 UTC
Scheduled
We will be releasing a hotfix for Self-service 'Deployed Apps' and 'Entitlements' (tabs in Control Center). This fix will address an urgent issues related to UI.
Both tabs will be unavailable for a short time during this hotfix.
Posted May 16, 2025 - 09:36 UTC
This scheduled maintenance affected: Mendix Services (Self-service).