This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
We will be updating our platform applications. During this time, below platform applications will be temporarily unavailable.
Academy (academy.mendix.com) Catalog (catalog.mendix.com) Mendix Portal (appinsights.mendix.com, epics.mendix.com, portfolio.mendix.com) Exams (exams.mendix.com) Forum (community.mendix.com) Marketplace (marketplace.mendix.com) Partners (partners.home.mendix.com) Mendix on Azure (mendixonazure.mendix.com) Mendix on Kubernetes (privatecloud.mendixcloud.com)
Posted Dec 03, 2025 - 09:43 UTC
Scheduled
We will be updating our platform applications. During this time, below platform applications will be temporarily unavailable.
Academy (academy.mendix.com) Catalog (catalog.mendix.com) Mendix Portal (appinsights.mendix.com, epics.mendix.com, portfolio.mendix.com) Exams (exams.mendix.com) Forum (community.mendix.com) Marketplace (marketplace.mendix.com) Partners (partners.home.mendix.com)
--------------
Posted Nov 06, 2025 - 08:03 UTC
This scheduled maintenance affects: Mendix on Third Party Clouds (Mendix on Kubernetes, Mendix on Azure), Mendix Cloud Services (Mendix Cloud Deployment), and Mendix Services (Studio Pro, Academy).