SIGN UP RE-CAPTCHA HOTFIX
Incident Report for Mendix Technology B.V.
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 17:33 CEST
Identified
The issue has been identified and we are implementing it.

Time of the fix is going to be 17:00 to 17:30
Posted Jul 22, 2024 - 16:51 CEST