All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Self-service hotfix

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 09:42 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 02, 2025 - 09:15 UTC

Investigating

We identified an issue in Self-service "Entitlements" (Control Center tab) and will deploy a hotfix to address it.
During this maintenance window Self-service "Entitlements" (Control Center tab) will be unavailable for about 15 minutes.
Posted Oct 02, 2025 - 09:14 UTC
This incident affected: Mendix Services (Self-service).