Self-service V3 - V4 migrations and backup uploading/restoring
Incident Report for Mendix Technology B.V.
Resolved
The issue has now been patched and resolved.

Customers can now continue with their self service migrations. Thanks for your patience while we resolved this issue.
Posted Apr 15, 2021 - 15:47 CEST
Update
The team is continuing to work with priority on the necessary fix, so that customers can once again perform self-service migrations.

Until then, out of an abundance of caution, we strongly advise all customers to postpone all V3 - V4 migrations where customers upload backups until further notice. This will ensure that migrations proceed as smoothly as possible.
Posted Apr 08, 2021 - 14:34 CEST
Identified
We have identified the cause of this issue and are working with priority to implement a mitigation, so that customers can continue with their self-service migrations.
Posted Mar 30, 2021 - 12:09 CEST
Investigating
We have received reports of problems when customers have uploaded a full backup during a V3 - V4 migration process which causes migrated apps to malfunction.

We are currently investigating the issue with priority, and correlating all reports to gain insight into the issue.

As such, out of an abundance of caution, we strongly advise all customers to postpone all V3 - V4 migrations where customers upload backups until further notice. This will ensure that migrations proceed as smoothly as possible.

If customers have a migration planned in the upcoming days, please contact Mendix Support to discuss next steps. Rest assured that whilst the official deprecation deadline of the Mendix Cloud V3 is 31st March 2021, any customers who have to postpone their migration as a result of this issue will be given ample time to complete the process.
Posted Mar 29, 2021 - 15:36 CEST
This incident affected: Mendix Services (Deploy / Operate - Mendix Cloud).