Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2023 - 14:30 CET
Scheduled
We will be releasing a new version of SignUp/SignUpService. All services on https://signup.mendix.com will be unavailable. You will not be able to sign up in Mendix during this time.
Posted Mar 13, 2023 - 14:11 CET
This scheduled maintenance affected: Mendix Services (SignUp).