Platform Maintenance

Scheduled for May 17, 05:00 - 08:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 06, 2025 - 07:24 UTC

Scheduled

Developer Portal (appinsights.mendix.com) : 5:00 - 8:00 UTC
Posted Apr 30, 2025 - 14:29 UTC