Mendix Cloud new application deployment issue in US East

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted May 07, 2025 - 07:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2025 - 23:16 UTC

Identified

We are currently experiencing a network issue that is impacting the ability to deploy new applications and perform upgrades. Existing applications that are not being modified continue to function as expected.

Our team has identified the root cause and is actively working on a fix. We’ll provide an update as soon as more information is available.

Thank you for your patience and understanding.
Posted May 05, 2025 - 22:07 UTC
This incident affected: Mendix Cloud (Mendix Cloud US-East).