All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Cloud Free Apps Degraded Performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 08:20 UTC

Monitoring

The hotfix has been released and free apps deployments are working again. We'll continue to monitor the results.
Posted Jul 29, 2026 - 15:13 UTC

Identified

The issue has been identified. We're planning to release this fix on 29 Jul at 1500 UTC as a hotfix.
Posted Jul 29, 2026 - 12:03 UTC

Update

We are investigating a platform incident with Free Apps. Customers may experience intermittent failures during free app deployments.

This incident will be updated in 1 hour, or as events warrant.
Posted Jul 29, 2026 - 06:47 UTC

Update

We are continuing to investigate the issue.
Posted Jul 29, 2026 - 06:46 UTC

Investigating

We are investigating a platform incident with Free Apps. Customers may experience intermittent failures during free app deployments.

This incident will be updated in 1 hour, or as events warrant.
Posted Jul 29, 2026 - 06:45 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud Free Tier EU).