This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
We have implemented a fix which enables additional availability zones for resource creation. We will keep monitoring the situation. Customers can continue deploying applications
Posted Jun 23, 2026 - 14:46 UTC
Investigating
We are facing issues with database provisioning in the Mendix Cloud UK cluster. Customers will experience issues while creating new apps but existing apps will work fine.
Issue is related to our cloud provider not having capacity on one of the availability zones.
Please do not deploy new applications if you are deploying for the first time, perform downsizes, or clear database during the incident.
Posted Jun 22, 2026 - 13:30 UTC
This incident affects: Mendix Cloud Services (Mendix Cloud Deployment) and Mendix Cloud Regions (Mendix Cloud UK).