This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
The situation hasn't changed. We have seen no improvement. The vendor is expecting recovery to take at least another day.
We will update the incident as events warrant.
Posted Mar 03, 2026 - 15:54 UTC
Update
We have identified an issue with an upstream vendor due to a regional incident, causing most applications in that region to be unavailable. The vendor is expecting recovery to take at least another day.
We will update the incident as events warrant.
Posted Mar 02, 2026 - 15:43 UTC
Update
We have identified an issue with an upstream vendor due to a regional incident, causing most applications in that region to be unavailable.
We will update the incident as events warrant.
Posted Mar 02, 2026 - 08:29 UTC
Identified
Due to a power outage in the data center where the standard plan applications are running, unfortunately those applications are inaccessible.
Posted Mar 01, 2026 - 16:07 UTC
Investigating
We are investigating an incident in the Middle East (UAE) region. Customers may experience problems when trying to access their applications.
Posted Mar 01, 2026 - 16:06 UTC
This incident affects: Mendix Cloud Regions (Mendix Cloud Middle East (UAE)).