All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 08:26 UTC

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Apr 28, 2026 - 15:03 UTC

Investigating

We are currently investigating an issue with some customers seeing 'Navigation Retrieval Failed' errors on Mendix Portal. Impacted customers are advised to logout and login again as a workaround until a proper fix is implemented.
Posted Apr 28, 2026 - 14:35 UTC
This incident affected: Mendix Cloud Services (Mendix Cloud Deployment).