All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Signups are failing

Incident Report for Mendix Technology

Resolved

We have not encountered any more issues. Marking this incident as resolved.
Posted Aug 12, 2020 - 11:58 UTC

Monitoring

We have deployed a fix and we are now monitoring the situation.
Posted Aug 12, 2020 - 10:11 UTC

Investigating

We are currently investigating issues with platform signups, therefore signups might not work as intended.
Posted Aug 12, 2020 - 09:34 UTC