Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 05, 2025 - 11:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 03, 2025 - 09:25 UTC
Scheduled
We will be updating our platform applications. During this time, below platform applications will be temporarily unavailable.
Mendix For Private Cloud (privatecloud.mendixcloud.com): 11:00 -14:00 UTC Mendix on Azure (mendixonazure.mendix.com): 11:00 -14:00 UTC Licensing service: 11:00 -14:00 UTC Self-service 'Entitlements' (Control Center tab): 11:00 -14:00 UTC Self-service 'Deployed Apps' (Control Center tab): 11:00 -14:00 UTC
Posted Jun 25, 2025 - 13:48 UTC
This scheduled maintenance affected: Mendix for Private Cloud (Deploy / Operate - Mendix for Private Cloud, Mendix on Azure) and Mendix Services (Licensing Service, Self-service).