All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Custom domains unavailable after restart

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 12:50 UTC

Monitoring

A fix has been implemented. Restarting the application environment recovers the custom domains. We will continue to monitor the results.
Posted Jul 23, 2026 - 10:16 UTC

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 09:35 UTC

Investigating

We are investigating an incident with custom domains being unavailable after restarting the environment. Customers may experience:

- The application being unavailable on the custom domain
- Custom domains not shown on Mendix Portal

We advise customers with a custom domain on their application to not restart or deploy to those applications for the time being.

This incident will be updated in 1 hour, or as events warrant.
Posted Jul 23, 2026 - 09:30 UTC
This incident affected: Mendix Cloud Deployment (Mendix Cloud Deployment, Custom domains).