Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 09:12 UTC

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Aug 04, 2025 - 08:28 UTC

Investigating

We are currently investigating error message popups on Mendix Portal.
Posted Aug 04, 2025 - 08:03 UTC
This incident affected: Mendix Services (Mendix Portal).