All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal partial outage

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 12:01 UTC

Monitoring

Access has been restored and we're monitoring the fix.
Posted Feb 19, 2026 - 09:59 UTC

Identified

The issue has been identified and a fix has been implemented.
Posted Feb 19, 2026 - 08:42 UTC

Investigating

We are investigating an issue with Mendix Portal. Customers may experience access issues for the Cloud Logs, metrics, alerts pages on Mendix Cloud.

This incident will be updated in 1 hour, or as events warrant.
Posted Feb 19, 2026 - 08:21 UTC
This incident affected: Mendix Cloud Services (Logging, Monitoring, and Alerting).