Mendix Cloud Free Apps degraded performance

Incident Report for Mendix Technology

Resolved

We have not received any further reports of issues from users since the last update. All services are operating within expected parameters.

Please redeploy your application if you have been affected by this issue.
Posted Aug 07, 2025 - 06:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Please redeploy your application if you have been affected by this incident.
Posted Aug 06, 2025 - 15:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 06, 2025 - 11:29 UTC

Identified

We have identified a platform incident with Free Apps. Some customers may experience a problem with deployment and resuming their free app.

This incident will be updated in 1 hour, or as events warrant.
Posted Aug 06, 2025 - 09:44 UTC
This incident affected: Mendix Cloud (Mendix Cloud Free Tier EU).