Licensing Service Hotfix

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 12:10 UTC

Investigating

We will be performing maintenance on the Licensing Service to resolve an issue, thus the app will not be available from 12:00 PM to 12:20 PM UTC time.
Posted Jun 19, 2025 - 11:50 UTC
This incident affected: Mendix Services (Licensing Service, Self-service).