All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Apps are not reachable

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted May 15, 2026 - 07:03 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted May 12, 2026 - 17:56 UTC

Identified

We identified the root cause. The team is working on solving the problem.
Posted May 12, 2026 - 17:19 UTC

Investigating

We are currently investigating the issue.
Posted May 12, 2026 - 16:49 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud Free Tier EU, Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud Middle East (UAE), Mendix Cloud South America (São Paulo), Mendix Cloud EU (Frankfurt 2), Mendix Cloud Asia Pacific (Osaka), Mendix Cloud Asia Pacific (Seoul), Mendix Cloud Asia Pacific (Jakarta)) and Mendix Cloud Services (Mendix Cloud Deployment, Logging, Monitoring, and Alerting, Backups).