All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix pipelines degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 14:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 14:22 UTC

Investigating

We are investigating an incident with pipelines component. Customers may experience slow responses

This incident will be updated in 1 hour, or as events warrant.
Posted Dec 09, 2025 - 18:46 UTC
This incident affected: Mendix Services (Pipeline Portal).