Resolved
This incident has been resolved.
Posted Aug 14, 2025 - 14:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 09:54 UTC
Identified
We are investigating an incident with Mendix Portal: Maintenance > Execute Now in all regions. Customers may experience that their PostgreSQL Upgrade task stays hanging in Queued state and/or that the app remains in Maintenance mode for an extended period of time. For this reason, we are advising our customers to not use the Execute Now button for the PostgreSQL Upgrade task until this incident is resolved. Apologies for the inconvenience caused, we've identified the cause and are working on resolving it.
This incident will be updated in 1 hour, or as events warrant.
Posted Aug 14, 2025 - 09:07 UTC
This incident affected: Mendix Cloud (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud Middle East (UAE), Mendix Cloud South America (São Paulo), Mendix Cloud EU (Frankfurt 2), Mendix Cloud Asia Pacific (Osaka), Mendix Cloud Asia Pacific (Seoul), Mendix Cloud Asia Pacific (Jakarta)), Mendix Cloud Dedicated (Mendix Cloud Dedicated EU (Frankfurt) Alfa, Mendix Cloud Dedicated US-West Alfa, Mendix Cloud Dedicated US-West Echo, Mendix Cloud Dedicated UK Echo, Mendix Cloud Dedicated Asia Pacific (Singapore) Echo, Mendix Cloud Dedicated US-East Hotel, Mendix Cloud Dedicated US-East Mike, Mendix Cloud Dedicated US-East Papa, Mendix Cloud Dedicated EU (Frankfurt) Sierra, Mendix Cloud Dedicated EU (Frankfurt) Uniform, Mendix Cloud Dedicated Asia Pacific (Singapore) Able, Mendix Cloud Dedicated US-East Kilo, Mendix Cloud Dedicated US-East Charlie, Mendix Cloud Dedicated US-East Colin), and Mendix Services (Mendix Portal).