All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Reduced capacity of database resources

Incident Report for Mendix Technology

Update

We have identified another region where we experience a reduced capacity of database resources.
Following plans are affected:
- L21(standard/premium)
- M21(standard/premium)
- XXXL(standard/premium)
Posted Sep 17, 2026 - 13:27 UTC

Update

We have identified another region where we experience a reduced capacity of database resources.
Following plans are affected:
- M21(standard/premium)
- XXXL(standard/premium)
Posted Sep 17, 2026 - 13:22 UTC

Identified

We have identified a reduced capacity of database resources for the following Mendix plan:
- XXXL(standard/premium)

We advise customers not to resize to the mentioned plan, until further notice.
Posted Sep 17, 2026 - 13:18 UTC
This incident affects: Mendix Cloud Regions (Mendix Cloud UK, Mendix Cloud Asia Pacific (Mumbai)).