All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal degraded performance

Incident Report for Mendix Technology

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2026 - 09:19 UTC

Investigating

We identified an issue in the deploy/promote flow that is causing Mendix SSO to fail after deployment. As a temporary workaround, stage the app and perform a restart, or restart the app if SSO is not working post-deployment. This ensures the required updates are applied and Mendix SSO functions correctly.
Posted Feb 11, 2026 - 12:12 UTC
This incident affects: Mendix Cloud Services (Mendix Cloud Deployment).