Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

A fix has been implemented and the incident is resolved.
Posted Aug 26, 2025 - 13:43 UTC

Investigating

We're currently investigating page load issues with Mendix Portal.
Posted Aug 26, 2025 - 12:48 UTC
This incident affected: Mendix Services (Mendix Portal).