All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal build process degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 11:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 07:48 UTC

Identified

We have identified an issue affecting the creation of deployment packages. In a small number of cases the build process is unable to reach the repository service.
Our team has pinpointed the root cause and is actively working on a permanent fix. In the meantime, retrying the build typically results in a successful deployment package.
Posted Sep 10, 2025 - 09:31 UTC
This incident affected: Mendix Services (Mendix Portal).