This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
The issue has resurfaced, we're continuing our investigation of intermittent connection issues with Mendix Portal. Customers are advised not to restart or deploy their applications. We will update the incident when we have more information.
Posted Aug 20, 2026 - 07:10 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Aug 19, 2026 - 14:19 UTC
Update
We are still investigating intermittent connection issues with Mendix Portal. Customers are advised not to restart or deploy their applications. We will update the incident when we have more information.
Scheduled (planned) PostgreSQL 17 upgrade maintenances have been postponed due to this incident and will be rescheduled, most likely next week.
Posted Aug 19, 2026 - 13:17 UTC
Investigating
We are currently investigating intermittent connection issues with Mendix Portal. Customers are advised not to restart or deploy their applications. We will update the incident when we have more information.
Posted Aug 19, 2026 - 10:45 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Aug 18, 2026 - 11:11 UTC
Investigating
We are noticing intermittent issues with our Mendix Portal.
We are investigating the issue. We will update the incident as events warrant.
Posted Aug 18, 2026 - 09:49 UTC
This incident affects: Mendix Cloud Deployment (Mendix Cloud Deployment).