All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

App deployment impacted on Mendix Cloud Dedicated EU (Frankfurt) Sierra

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 19:26 UTC

Monitoring

The dedicated DNS server upon which we depend is working again, and we see a restoration of service in our cluster. Deployments are working again, and we'll keep monitoring the situation for the time being and watch for regressions. Customers are advised to redeploy if they were affected.
Posted Mar 17, 2026 - 18:41 UTC

Investigating

We are investigating DNS issues that limit the mxapp (re)deployment capability.

Only Mendix Cloud Dedicated EU (Frankfurt) Sierra is impacted.

We advise customers in this region to refrain from redeploying until this issue is resolved.
Posted Mar 17, 2026 - 18:16 UTC
This incident affected: Mendix Cloud Dedicated Regions (Mendix Cloud Dedicated EU (Frankfurt) Sierra).