All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Platform Maintenance

Scheduled for Oct 12, 06:00 - 08:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 24, 2026 - 11:02 UTC

Scheduled

We will be performing an update to our alerting stack on Mendix Cloud. During this maintenance window, alerting functionality may be temporarily unavailable.
Posted Sep 24, 2026 - 10:56 UTC
This scheduled maintenance affects: Mendix Cloud Regions (Mendix Cloud US-East, Mendix Cloud US-West, Mendix Cloud Canada (Central), Mendix Cloud South America (São Paulo)) and Mendix Cloud Dedicated Regions (Mendix Cloud Dedicated US-West Echo, Mendix Cloud Dedicated US-East Hotel, Mendix Cloud Dedicated US-East Mike, Mendix Cloud Dedicated US-East Papa, Mendix Cloud Dedicated US-East Kilo, Mendix Cloud Dedicated US-East Charlie, Mendix Cloud Dedicated US-East Colin).