Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 14:45 UTC
Scheduled
We will be performing maintenance on the Mendix Portal to address an ongoing incident. During this maintenance window, all services on cloud.home.mendix.com will be unavailable. You will not be able to deploy apps during this time.
Posted May 28, 2025 - 14:28 UTC
This scheduled maintenance affected: Mendix Services (Deploy - Mendix Cloud).