Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2025 - 16:00 UTC
Scheduled
We will be performing a brief maintenance on the deployment functionality of our platform to update a back-office feature. During this time, the following platform services may experience intermittent availability. The expected downtime is expected to be no more than 15 minutes.
Deploy - Mendix Cloud
Posted Mar 10, 2025 - 13:29 UTC
This scheduled maintenance affected: Mendix Services (Deploy - Mendix Cloud).