This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
The maintenance has been completed successfully and all the services have been restored. If you face any issues please contact Mendix support.
Posted Feb 19, 2026 - 09:14 UTC
Verifying
The database infra has been upgraded successfully. We are now performing checks to verify the upgrade.
Posted Feb 19, 2026 - 09:13 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2026 - 08:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 17, 2026 - 12:45 UTC
Scheduled
Mendix Event Broker's supporting services will be temporarily unavailable due to upgrading of database infrastructure. During this time, Mendix Event Broker should continue to function as expected and there should not be any downtime expected for sending and receiving of messages. Deployment with new business events will not be supported during this period.
Posted Feb 17, 2026 - 12:40 UTC
This scheduled maintenance affected: Mendix Cloud Services (Mendix Event Broker).