This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
The current solution to this issue is to install "Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.439.210.0)".
This has solved current running incidents, but we are narrowly monitoring this with our customers to make sure all issues are resolved.
Posted Oct 17, 2025 - 12:06 UTC
Investigating
With the October 14 update of Windows 11, Studio Pro 9, 10, and 11 can show errors in different panels and editors making it unusable.
When you see the message "Hmmm... can't reach this page" with an error code of `ERR_CONNECTION_RESET`, in a tool panel or editor, your workstation is likely affected. Example panels where it can occur are the design properties and toolbox. Example editors are the Microflow, Nanoflow and Rule editor.
The current known workarounds for this problem are: - Install "Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.439.210.0)" or - Uninstall the following Windows updates: KB5066835, KB5066131, and KB5065789
We are actively investigating this issue and will update regularly.
Posted Oct 15, 2025 - 16:37 UTC
This incident affects: Mendix Services (Studio Pro).