All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Cloud: Application platform service degradation

Incident Report for Mendix Technology

Update

As we continue to fix the underlying platform, we have prioritized production environments to minimize impact.

Deployment errors have significantly decreased as the fixes are being applied. We are continuing to work towards complete recovery and will provide an update once all systems are fully restored.
Posted Jul 16, 2026 - 18:38 UTC

Identified

We are currently applying fixes to the underlying servers where the issue was identified.

As part of this remediation, some environments may restart while we are fixing the issue, these restarts are expected and necessary to resolve the problem. Please continue to avoid new deployments until we confirm the fix is complete.
Posted Jul 16, 2026 - 17:25 UTC

Update

We have identified the issue also impacts Mendix Cloud US-East and Mendix Cloud Dedicated EU (Frankfurt) Sierra regions.

We have identified the root cause of the deployment failures and unexpected environment restarts affecting multiple regions.
Posted Jul 16, 2026 - 17:02 UTC

Update

Additional Impact Identified:
Some environments in Mendix Cloud EU- Frankfurt 1 and Frankfurt 2 have experienced unexpected restarts.
We are investigating whether this is related to the deployment failure issue.
Posted Jul 16, 2026 - 16:51 UTC

Investigating

We are currently experiencing issues with deployments in our Mendix Cloud EU: Frankfurt 1 and Frankfurt 2 region. Multiple deployments are failing at this time.
Please do not attempt to deploy applications to Frankfurt 1 or Frankfurt 2 regions until this issue is resolved.

We are aware of this issue and our team is actively investigating. We will provide updates as more information becomes available.
Posted Jul 16, 2026 - 16:42 UTC
This incident affects: Mendix Cloud Regions (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud EU (Frankfurt 2)) and Mendix Cloud Dedicated Regions (Mendix Cloud Dedicated EU (Frankfurt) Sierra).