All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal reduced functionality - Mendix Cloud Middle East (Bahrain)

Incident Report for Mendix Technology

Resolved

Yesterday's logs for impacted applications have been recovered and the incident has been resolved.
Posted Oct 14, 2025 - 14:13 UTC

Monitoring

The logging service is back up and we're monitoring the results. Today's logs for all applications in Mendix Cloud Middle East (Bahrain) region are affected.
Posted Oct 13, 2025 - 16:05 UTC

Investigating

We are currently investigating issues with logging service in Mendix Cloud Middle East (Bahrain)
Posted Oct 13, 2025 - 15:52 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud Middle East (Bahrain)).