All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 09:13 UTC

Monitoring

Mendix portal experienced intermittent slowness/inaccessibility earlier today.
After a restart and close monitoring, it is now fully operational. We apologize for any disruption.
Posted Sep 15, 2025 - 13:58 UTC
This incident affected: Mendix Services (Mendix Portal).