All environments have been successfully started and are now functioning normally. The maintenance-related startup issues have been resolved.
Posted Aug 25, 2025 - 22:52 UTC
Monitoring
We are now starting all environments that are in the wrong state and will monitor the situation.
Known Issue: There is a display bug where the Developer Portal shows environments as "Maintenance" even though the applications are started and fully functional. Only environment management functions in the Developer Portal are affected.
Posted Aug 25, 2025 - 20:35 UTC
Identified
If you're experiencing startup issues after maintenance, you can resolve this by stopping and starting your environment in the Developer Portal.
Steps: - Go to your Developer Portal - Stop your environment - Start it again
Note: The Developer Portal may still show an error with "maintenance in progress." This is a known issue that we're working to resolve. We'll update this page within one hour with further details.
Posted Aug 25, 2025 - 19:32 UTC
Update
We are continuing to investigate this issue.
Posted Aug 25, 2025 - 18:48 UTC
Investigating
We are investigating an incident with maintenance in all regions. Customers may experience problems starting up the environment after maintenance.
This incident will be updated in 1 hour, or as events warrant.
Posted Aug 25, 2025 - 18:47 UTC
This incident affected: Mendix Cloud (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud Free Tier EU, Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud Middle East (UAE), Mendix Cloud South America (São Paulo), Mendix Cloud EU (Frankfurt 2), Mendix Cloud Asia Pacific (Osaka), Mendix Cloud Asia Pacific (Seoul), Mendix Cloud Asia Pacific (Jakarta)).