We have not received any further reports of issues from users since the last update. All services are operating within expected parameters.
Posted Aug 01, 2025 - 08:00 UTC
Monitoring
We have identified the root cause of the Mendix Cloud application start-up issues and have implemented corrective actions. Applications should now be able to start normally.
We are actively monitoring the situation to ensure full resolution. If you continue to experience problems, please reach out to Mendix Support.
Posted Jul 31, 2025 - 18:14 UTC
Investigating
Mendix Cloud applications are currently unable to start across several regions, resulting in service unavailability for affected applications.
Posted Jul 31, 2025 - 17:57 UTC
This incident affected: Mendix Cloud (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud UK, Mendix Cloud IE).